FTP Connection failure with EAI_NONAME error

by . Originally posted

While trying to use FileZilla FTP client the other day, I copied in a clients details to the configuration panel, hit connect and was shown the following error:

Status:	Resolving address of XYZ
Status:	Connection attempt failed with "EAI_NONAME - Neither nodename nor servname provided, or not known".
Error:	Could not connect to server

Now I’ve never even heard of an EAI related error, so this was a bit strange. I assumed the client had provided me with incorrect details, as its quite easy to do. I double checked the other FileZilla options and everything seemed ‘normal’.

To cut a long story short it turns out that EAI_NONAME basically translates in laymans terms to “Server couldn’t be found“. If you’re connecting via IP, make sure the host resolves to it by running “PING hostname” in a Microsoft Windows command prompt for example, or using an online free service.

If you’re connecting via a server hostname, make sure it contains no spelling mistakes or extra spaces.

If you get this error message don’t worry about changing default file paths, username or passwords to experiment. The FTP program can’t find the server, so can’t even get to checking those details.

Categories: Computing, Fixes & Solutions

Tags: , , ,

4 Comments

Leave a Reply to Rosemarie Cancel reply

Your email address will not be published.

Links and useful footery things…

Copyright © 2017 Paul Joyce. Follow me on Twitter or perhaps Google+