Updating Chromium on Debian 6 (Squeeze)

by . Originally posted

Chromium 18 on DebianSwitching between Ubuntu and Debian machines, you notice the benefits of both system OS’ quite quickly. The first major thing you’ll probably have noticed with Debian 6 (Squeeze) is that its bundled with Chromium.

After a bit of use though, you’ll also notice how unstable Chromium is. Lots of web pages freezing up, tabs not responding and having to be killed off. Not ideal. That’s because of one of the mixed blessings of Debian – long stable releases.

That’s right, Chromium is unstable because Debian is bundled to be stable. It makes sense when you take on board the Debian ethos and release schedule, however annoying it might be to new users.

The Chromium browser shipping with the latest Debian OS is Chromium 6. In contrast, the latest Chromium version out there is 26!

I couldn’t quite believe this. 20 major version releases of code that we’re running without. No wonder its unstable.

The version us Debian users are given by default was released back in May 2010.

Check you’re running Chromium 6.0.472.63

Before we update, lets first check we’re all on the same page.

Run the following code from your terminal:

dpkg -p chromium-browser

This will poll the package manager for information on the installed version of Chromium you have. Hopefully you should results like the screenshot below. Notice the line that is highlighted, yours should be similar.

Chromium Browser v6.0.472.63 on Debian Squeeze

Chromium Browser v6.0.472.63 on Debian Squeeze
(Click to view larger)


Grabbing the daily Chromium build

Debian by default uses stable builds of software, but we’re going to have to open a few doors to get a newer piece of shiny Chromium software. Unfortunately we can’t jump all the way to the latest v26 of the software, as too many library dependencies have changed. The scope of such a feat is well beyond this article, and beyond the purpose of just updating your web browser. We can however get to version 18, which is a huge difference in terms of stability, security, reliability and built in features.

Back in the terminal we need to add a new list to the sources file. This tells your package manager where to get new packages from. Make sure you’re admin and open the sources.list file:

nano /etc/apt/sources.list

You should see a small document like this:

Adding Chromium repo to sources.list on Debian

It may have a few more lines in it, however if its completely different just double check you’ve opened the right file.

Add the following line:

deb http://ppa.launchpad.net/chromium-daily/ppa/ubuntu lucid main

Save and close the file.

Now to make sure everything is transferred safely and your system is kept as secure as possible, you need to add a GPG key to the APT controller. Run the following in terminal:

(GPG stands for GNU Privacy Guard)

apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 4E5E17B5

You should see several messages appear from GPG, including:

GPG: key 4E5E17B5: public key "Launchpad PPA for chromium-daily" imported
...
GPG: imported: 1 (RSA: 1)

If you get any errors drop them in the comments below and I’ll try and guide you through a fix.

Grabbing a stable Chromium 18 build

Now everything is in place for the actual new version to be installed.

Note: Before we go any further, you should close any Chromium browsers you have open otherwise the packages may be blocked from updating. Either print out this page, open it in another browser or copy it to some text editor.

With your Chromium windows closed, run the following from Terminal:

aptitude update && aptitude upgrade chromium-browser

If all goes well, it should ask you if you’re sure to add additional packages. This is standard behaviour and you should just confirm you’re happy to to download the extra few MB of files.

After a few more seconds you should be dropped back at a waiting Terminal screen.

Assuming no errors were thrown at you, head over to your Chromium icon and load her up.

You should be greeted with version 18 (build 130497 Linux). 

Safe and happy surfing!

If this article helped you and saved you from many crashed tabs in Debian, please spend a few seconds dropping me a comment or giving this article a share, it’d be greatly appreciated.

Categories: Computing, Fixes & Solutions, Linux

Tags: , , , ,

8 Comments

  • Dan E says:

    No, this hasn’t worked on my system. I am not a linux jockey, although I have some background with commercial Unixes. I use this only as a platform for OpenOffice and browsing. The basic OS seems very stable and I do not want to go through the involved process of upgrading the whole system. I just need the browser to be reasonably secure.

    After trying your command line process, I’ve tried several edits of /etc/apt/sources.list. The upgrade icon displays red in upper rt corner, but the upgrade fails with an error, “can’t find…” whatever. I’ll send whatever capture in separate emails. Thanks.

  • Oleg says:

    Thank you, Paul. All was good, but the last command give me an error: about blocking “/var/lib/dpkg/lock” (can’t translate it from russian). But apt-get update was successfull, and then “apt-get upgrade chromium-browser” was successful too. Thank you, very much.

  • Alan says:

    Thank you Paul for this wonderful information.

    I tried Wheezy, but it is terrible. Squeeze (Gnome 2) is the greatest. Chromium was an issue….

    Now sorted, thanks to your efforts.

    Blessings,
    Alan.

  • Artem says:

    Thanks a lot! Not only me have this trouble 🙂 Debian 6 is on my server and Selenium tests (in Xvfb) does`t want to run because of old glibc. I will upgrade to Debian7/7.1.

  • Miikka says:

    Thanks Paul! It worked fine for me except the last step with aptitude update and upgrade chromium-browser.

    I got the following error:
    aptitude update && aptitude upgrade chromium-browse

    E: Could not open lock file /var/lib/dpkg/lock – open (13: Permission denied)
    E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

    It was probably just because of Synaptic running. When i let Synaptic do the updating there was no problem.

  • John says:

    Hey Paul, I’ve followed every step in the guide. But once I type in the ,”aptitude update && aptitude upgrade chromium-browser” command I get this:

    W: GPG error: http://packages.crunchbang.org squeeze-backports Release: The following signatures were invalid: KEYEXPIRED 1352888501

    E: Could not open lock file /var/lib/dpkg/lock – open (13: Permission denied)
    E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

    I ran it using sudo. But it doesn’t seem to work? Any help is appreciated Paul.

    • Paul Joyce says:

      Hi John. Thanks for the post. Do you have any other terminal or package update managers open? Such as the Synaptic Package Manager? If so close those first, then try re-running the command. Failing that, just type “su”, enter the root password and try again (w/o the sudo command).

    • Paul Joyce says:

      Ah sorry John, just noticed you’re running on CrunchBang – that might have something to do with it. Try the suggestion in this CrunchBang squeeze-backports post, although I can’t vouch for it as I’m not running CB. Let me know if any of the suggestions work. Paul

Leave a Reply

Your email address will not be published.

Links and useful footery things…

Copyright © 2017 Paul Joyce. Follow me on Twitter or perhaps Google+